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Part 1: Introduction 

What is OpenOffice.org?

OpenOffice.org is a full office application suite consisting of a word processing component 
(OpenOffice.org Writer), a spreadsheet component (OpenOffice.org Calc), a slide show 
presentation component (OpenOffice.org Impress), a database component (OpenOffice.org 
Base), a drawing and flow sheet component (OpenOffice.org Draw), and a calculator component 
(OpenOffice.org Math). This entire suite of applications is part of the Open Source initiative, 
meaning that the software's code is open to the public for input and suggestions for future 
versions of the software. In addition to the code being open to the public, the software itself is 
open to the public, meaning that the entire suite of applications is entirely free. This free software 
is just as comprehensive, if not more so than, similar software such as Microsoft Office, which 
retails at hundreds of dollars. In this section of the curriculum, we will focus on the presentation 
component of the OpenOffice.org suite.

A) What is OpenOffice.org Impress?

 Impress is a presentation program that is part of the OpenOffice.org office suite. 
 It allows you to create presentations where you can demonstrate or show projects, reports, etc 

that you have learned to an audience. 
 Visual Aid, in slideshow presentation format

B) Launching Impress 
    From the Start menu click on 

Programs >
OpenOffice.org > 
OpenOffice.org Impress  

The program will, by default, start 
with the Presentation Wizard. We 
will discuss this later. 
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C) Familiarization with the Impress window

Title Bar Menu Bar Standard/Formatting Bar 

Left Task 
Panel 
                                                              Slide                                       Right Task Panel 
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In the Right Task Panel there are the following options:

• Master Pages: Every slide in a presentation has exactly one slide master, also known as 
master page. A slide master determines the text formatting style for the title and outline 
and the background design for all slides that use this slide master

• Layouts: these layouts are different templates for creating a slide. There are a wide 
variety of ways to arrange your slide depending on the amount of text and media. These 
layouts help you work with a blueprint of the basic shape you want your slide to look 
like.

• Custom Animation: this feature allows you to animate certain text fields or graphics 
within an individual slide.

• Slide Transition: This feature is for the manipulation of the effects in between slides. 
This is where you will find the many different transitions available for use in between 
two slides.
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Part 2: New Presentation 

A) Presentation Wizard
• The Wizard provides pre-made presentation templates with different backgrounds and 

effects to choose from. 
• These templates are more detailed than the layouts, often complete with background 

graphics.

The 1st step of the wizard has the following options
• Empty Presentation – creates a new presentation starting with 1 blank slide.
• From template- creates a new presentation from a predefined blueprint
• Open existing presentation- open a previously saved presentation.

1. Unless you have a template which you wish to use, it is easiest to start the from scratch 
with an empty presentation.
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2. The second step of the Presentation Wizard allows you to select a background for your 
slide as well as the medium on which it will be presented.

3. Step 3 of the wizard allows the user to set the default transition in between slides. If there 
is some transition that you would like to use for all the slides, then this is the best place to 
set it. Otherwise, you would have to set the transitions manually for each slide.

7



B) Applying Layouts
1. The slide that appears is the title slide, labeled Slide 1. 
2. Select the layout in the top right corner of the Layouts window in the right panel of the 

program. This will add a text box for the title and body of your slide.
3. Click on Click to add title and type in Intro to Impress. In the Click 

to add subtitle area click and type your whole name and today’s 
date. 

4. The Right Task Panel should read Layouts.  
Scroll through looking at the different options for your slide layout. 
Once you choose one, write:

• Text Layout 
• Content Layout 
• Text and Content  Layout 
• Other Layouts 

5. To add the Layout slide you have chosen (we will do it as a class)
a. Under Layouts, select the bulleted list layout. 

Right click the layout you wish to use from the pull down list 
and select Insert New Slide. 
b. Click in the Click to add title area at the top of 

the slide and type What is OpenOffice.org Impress? 
c. Click in the Click to add outline to create a bulleted list. 

Write:
Presentation software that uses text (press Enter)
• Graphics ( press Enter)
• Video ( press Enter)
• Sound

6. Add a new bulleted list slide

7. From the tabs above the slide panel, select Outline view.
8. Create a new slide by right clicking in the Left task panel using the 

outline view and selecting New Slide. This slide will be a blank slide, 
which must have the bulleted list layout applied to it.

a. Title: Why use Impress?
b. Bulleted point: To communicate (press enter)
c. Subpoint: press enter key: Effectively (press enter)
d. Second subpoint: Appropriately (press enter)
e. To return to a bulleted point hold down the Shift

key and press the Tab key. 
f. Bulleted point: To enhance the presentation 
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9. Create a new slide from the Insert menu or press CTRL-E (a short cut for creating a new 
slide) Use the Slides or Outline view – your choice. 

a. Title: Text
b. Bulleted points:

• The Good 
• The Bad
• The Ugly

10. Changing Slide Order 

Impress allows you to change the order of slides in your presentation quickly and easily. 
The easiest way to view and change the order of slides is in the Outline View, Normal 
View, and Slide Sorter View. 

To change the order of slides in Outline View:

• Click and hold on the slide icon of the slide 
that you would like to move

• Move the mouse pointer to the new 
location of the slide. As you move the
pointer, a black line will appear that 
shows you the new position for the slide. 

• Release the mouse button.   

* Do the same to change the order of the 
slides in the Slide View.
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To change the order of the slides in Slide Sorter View: 
• Click on the slide that you would like to move and hold the mouse button down
• Move the pointer to the space between the two slides that you would like the 

selected slide inserted between. A line will appear.
• Release the mouse button.

Notice the darkening around Slide 4 designates that it is the selected slide. The black bar 
between Slides 1 and 2 represent the position that the selected slide will be moved to.
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Slide Sorter view after the switch:

        11.  Deleting Slides 

There are several ways to delete slides. 

To delete slides in the Outline View: 
• Place pointer over slide icon until it changes to a four sided arrow. 
• Click once to select slide icon. 
• Press the delete key on the keyboard.

To delete slides in the Slide Sorter View:
• Click once to select slide icon. This creates a darkened boarder around the 

selected slide. 
• Press the delete key on the keyboard.
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To delete slides using the Delete Slide Command:
• Select slide to be deleted by highlighting it or by viewing it.
• Click on the Edit Menu and select Delete Slide. 

11. Creating a Notes Page 

A presenter has two jobs when developing a presentation. One is to create slides that 
contain concise messages which clearly communicate the presenter's information. The 
second is to communicate verbally, putting each slide’s message in perspective. By 
creating notes pages, the presenter has an organized way of keeping up with the slide 
order and notes about the slide. 

To create Notes Pages:
• Select the slide for which you wish to create a Notes Page.
• From the tabs above the slide pane, select Notes
• The slide image will appear in the top half of the page and a text area will appear 

in the bottom half of the page. 
• Click in the bottom half of the Notes Page and type your notes. 

* Notes do not appear when 
visiting slide show. They 
must be printed out in order  
to see them.  They are 
intended more for the 
presenter than the audience.

Slide 

Notes Page 
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Part 3: Save Presentation

You should save your presentation to prevent loss of work. Remember to save frequently. 

To Save your Presentation: 

• File > Save 

• Click on Desktop

• Name your file In the File 
Name box

• Press Save 

• Continue to save the 
presentation from time to 
time. 

• For this class we are saving on the desktop, however you should use a disk and save your 
work on a disk.
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Part 4: Using Slide Master 

One of the most useful tools in Impress is the Slide Master. A slide master contains instructions 
on the background design, the background color, text color, font, and font size. This allows you 
to give your presentation a consistent appearance throughout. There are two masters available: 
Slide and Notes Pages. 

• From the View Menu, choose Master and then Slide Master. 
• A master slide for the presentation will appear. It contains a position box for the title 

and a position box for the body text. These positions boxes can be placed where you 
wish, and will appear in these locations on all slides. 

• To insert a date, click in the text area and select Insert and Date and Time. To have 
the date and time continuously updated, check the box marked Variable.

• To insert a page number, click in the text area and select Insert > Fields > Page 
Number

• Text boxes will appear which may be dragged to any position in the text area. The date 
and page numbers will now be placed on all slides. 

• When completing your work in the Slide Master, change back to an appropriate view 
… from the view shortcut icons or the View Menu.  
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Part 5: Getting Help 

Impress offers Help at two levels. 

For a detailed explanation of a topic, how to perform a series of steps, or to have a question 
answered: 

• Click on the Help menu and scroll to OpenOffice.org Help. 

For a quick explanation of a button, scrollbar or ruler:
• Click the arrow/question mark What's This? button from the Help menu. 
• Click on the item on the screen where you need help. Impress will display a brief 

description of the item and its function. 

If further help is required, then please call the following number for any additional technical 
support questions you may run into: 860-297-4277

As always, the internet is an endless source of information. Try using www.google.com to search 
for any information you may need about the software and how to use it.
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Part 6: Refining Your Slides

Using Fontwork Gallery                                                                
1. From the Drawing toolbar at the bottom of the Slide pane, select the Fontwork Gallery 

icon

2. Select a font style from the Gallery and click OK.
3. This will place a word image Fontwork in the center of your slide. This can be moved 

anywhere in the slide.
4. By clicking on the word, text appears over the image. This text field is where you will 

replace the word Fontwork with whatever you wish.
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Editing Fontworks

1. Notice a new toolbar appeared when the Fontworks was added to the slide. This is the 
Fontworks toolbar and is where you can change shape of the Fontworks, the letter height, 
the alignment, the character spacing, and various tools to manipulate the 3D effects used 
by Fontworks.  

• Insert a new Fontworks
• Edit the text of your Fontworks
• Go to the Fontworks gallery to choose a different style. 
• Format Fontworks leads to changing colors & lines, size and layout. 
• “Abc” leads to the Fontworks shapes. 
• Fontworks letter heights 
• Text direction
• Alignment 
• Character Spacing 

2. Try out different visual effects to find one that you like 
• The yellow circle at the left side allows you to stretch or distort the letter image 

by click on it and dragging your arrow.
• Blue squares allow you to resize the image by click on it and moving your arrow. 
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Add an external photograph or picture to your slide
1. Minimize Impress. (Click on the little dash button in the upper right corner.) 
2. Open the Web browser (Mozilla Firefox) 
3. Surf the net to find a picture you like. (You can go to http://images.google.com)
4. Once you locate a picture you like, 

move the cursor over the image and 
hold down the right mouse button 
until the pop-up menu appears. Press 
Save Picture As… Save the picture 
to the desktop. Remember where 
you save it and what you named! It 
is easiest at first to save images to 
the desktop.

5. Return to Impress. (Click on the OpenOffice.org 
Impress button on the TaskBar). 

6. Go to the slide where you wish to add the 
picture. 

7. From the Insert menu, select Picture, then 
From File…

8. Find the image you saved from the Web and 
double click on it. It will insert itself onto your 
slide.

9. Resize the image as necessary. 
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Add a line drawing using the Impress graphics tools.
1. Notice the Draw Toolbar at the bottom of the window. 
2. Choose Stars and Banners, then pick a shape. Use the mouse to drag the shape to the 

size you like. 

3. Fill the shape with a different color. 
a. Click on the shape to select it. 
b. Use the drop down 

menu on the Line 
and Filling Toolbar 
that appears when 
you select the shape 
to change the color of 
the shape.

Line and Filling Toolbar
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Part 7: Creating a Slide Show with Transitions and Builds 

(Transitions = how you move from slide to slide) 

Transitions 
1. From the Slide Show Menu, select Slide Transitions 
2. From the Slide Transition pane, explore the various options. 
3. You can Modify Transition Speed or add a Sound. You can also Advance Slide with 

each mouse click. 
4. Transitions can be applied to selected slides or all slides.
5. To view a preview of the transition, click on the Play button. 
6. While in the Slide Sorter, a small transition icon appears beneath

And to the left of each slide that has a transition applied. 
7. To run the Slide Show

a. Click on the Slide Show icon or from the menus, select
Slide Show > View Slide Show

b. Click on the left mouse button, space bar, enter key, etc.
to advance one slide.

c. Press ESC to exit slide show.
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Builds – Custom Animation 
When designing a slide show, remember that your content should remain the center of your 
presentation. You want any of the tools you use in your presentation, such as builds and 
transitions, to emphasize your points rather than drawing your audience’s attention to special 
effects. Builds allow you to design your text so that bulleted points and objects appear one at a 
time. For example, since your audience is used to reading from left to right, design your “build” 
slides so that text files in from the right. Only have text fly in from the left 
when you want to emphasize a point. 

To apply a build to a specific slide to be animated:
1. Select slide and the text area or graphic
From Slide Show > Custom Animation panes select Add..., 
then select one of the four effects: 

• Entrance 
• Emphasizes
• Exit
• Motion Paths

Practice: Select the Entrance tab and then select Appear from the list

• Use pull down menu for the animation 
• Select Effect Option 
• In the Appear window, under the Effect tab enhancements

• Sound (none or what kind) 
• After animation, whether you don’t dim or select
  color to dim to how you want the text to be appear 
   (all at once, by word or by letter) 
• Take a look at the Timing tab
• Take a look at the Text Animation tab
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Part 8: Video 

Inserting and Animating Video 
1. Click Insert > Movie and Sound
2. Click the movie clip you would like to insert into 

your presentation.  
3. To animate the video, right click on the video 

icon. A shortcut menu will appear. Click Custom 
Animation. 

4. Choose the animation you are interested in. 

Part 9: Saving and Printing Your Presentation

1. Don’t forget to save your presentation several times as you work on it
2. Go to File > Save to start the save feature or click on the save diskette icon.
3. Choose where you want to save the presentation. Impress presentations do take up a lot of 

space, especially those with a significant amount of pictures or video. 
4. To Print the presentation, simply go to File > Print from the menu bar or pressing the 

Print icon from the Standard Toolbar.
5. This will open a 

window asking which 
printer to use, 
normally the default 
printer is fine. If you 
had a color printer and 
a laser printer 
installed, you may 
wish to use the color 
printer to print the 
presentation.
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